SharePoint 2013 Prerequisite Installer Failure
Today I was at a client for a new SharePoint 2013 installation and I kept having strange errors when running the SharePoint 2013 Prerequisite installer! Here is the error stack I got:
WARNING: 2014-05-28 16:09:48 – Error: Call to StartService function to start the service failed (0X422=1058)
WARNING: 2014-05-28 16:09:48 – Error: [In HRESULT format] (0X80070422=-2147023838)
WARNING: 2014-05-28 16:09:48 – Error: Unable to start windows update service (0X422=1058)
WARNING: 2014-05-28 16:09:48 – Error: The tool was unable to install Windows Server AppFabric.
WARNING: 2014-05-28 16:09:48 – Last return code (0X422=1058)
It took me a while to find the fix, but it was easy! To fix this error, you simply have to make sure that your Windows Update service is not set to disabled! Just set it to Start Automatically and start it, and your prerequisite installer will run with no problems afterwards!
